Resolved
Disruptions at Telia affect the ability to contact support by phone

Started
2023-01-23 at 14:06
Status
Resolved after about 17 hours

Impact

Operational
Affected
Haldor Education (Huvudtjänst)
Haldor Vårdnadshavare
  • Resolved
    2023-01-24 at 07:27

    It is now possible to reach our support by phone. The previous disruption in Telia's network has been resolved.

  • Investigating
    2023-01-23 at 14:06

    Due to disruptions in Telia's network, it is currently not possible to contact our support by phone. But we can be reached as usual via email: support@haldor.se