All systems operational

Resolved
Sevice outage at Microsoft effecting Haldor Education

Started
2023-01-25 at 09:54
Status
Resolved after 5 days

Impact

Degraded performance
Affected
Haldor Education (Main service)
Haldor Guardians
  • Resolved
    Resolved

    Microsoft's service outage is now resolved.

  • Identified
    Identified

    Microsoft is experiencing a service outage for several of their Microsoft 365 services. This effects Haldor Education and causes some users to experience longer response times than usual.

    We are continuously monitoring the outage at Microsoft.