Our services are now up and running again. We will continue to monitor updates from our service provider and the major outage at Telia that was the underlying cause of the issues.
Identified
Identified
The major outage at Telia is ongoing and their technicians are working to resolve it. Unfortunately, there is no estimated time for a resolution yet.
Monitoring
Monitoring
The major outage at Telia is also affecting our services. We’re keeping an eye on the situation and will restore our services as soon as we see Telia’s infrastructure back up and running.
Identified
Identified
We’re currently experiencing a service outage.
We are working to restore service as quickly as possible.